Main Menu


File Menu

New - erases the MusicWonk Module Workspace, and any Widgets that were in the Panel. If there were changes made to the current Workspace you will first be asked if you want to Save.

Open... - invokes a standard Windows dialog box to open a previously created MusicWonk patch (.awp) file. You can also open patch files double clicking on the file name in the Windows explorer or by dragging them onto the MusicWonk Workspace; and when you first load MusicWonk if a valid patch file name is given in the command line, the file will be opened at startup.

Save - Saves the currently opened .awp file. If none have been opened, acts as Save As.

SaveAs... - Invokes the standard Windows File Save dialog to save the MusicWonk patch.

Quick Save - Saves the current patch as a Quick file for fast access file. There are 10 Quick files, named Quick0 to Quick9. These are rotated so that Quick Save will always save to the one least recently used. The menu indicates which of the Quick files is to be saved next.

Quick Load - Loads the last unnamed Quick Save patch. The menu indicates which of the Quick files was last saved, and this is the one it will load. If you need to load a previously saved Quick File, you can use the Open command to load it from the Patches/Quick directory.

Open Quick - Opens the Quick Save file history, so you can open a Quick Save file from up to 10 previous saves.

Load BioSeq... - Invokes an open dialog to load Bio Sequencer .bst files created by the Bio Editor. MusicWonk's BioSeq module uses these files to read and sequence DNA and amino acid data from genetic sequence files.

Load Tuning Table... - Opens a Tuning Table .pbt data file created by MicroTone and makes it the current source of tunings for the MIDI Tone modules. Does not alter the default tuning table file.

Import MIDI File... - Invokes a dialog box for importing MIDI files and converting them to a sequencer format that is compatible with the MusicWonk MIDIFile Module.

The dialog has a window on the left that shows all the tracks that are in the MIDI file, one on the right that shows the events within a track, and a column of16 channel buttons in the middle, which will show which channels are available on the selected track. Often there is only one MIDI channel per track; sometimes there is only one track with multiple channels. Whatever the combination of tracks and channels within a track, the channel buttons will become enabled for however many tracks there are, and if more than one you can choose a particular channel.

The window on the right allows you to select the actual MIDI message data to be imported. Click on Save or double click on an item in the MIDI Data (right side) window, and a file save dialog box pops up with the file already named with the original filename plus the track number and message-type (Vel (velocity), Key, Pan, etc) appended. The event data is saved in a special format that is optimized for efficient playback by the MIDI File module.

Exit - Exits MusicWonk. If there were changes made you will first be asked if you want to Save. Same as the Windows Close "X" icon in the upper right of the title bar.

Recently Opened File List - The 8 most recently opened files are listed here. Select a file name to open it.


Options Menu

Notes Off - Turns off stuck notes on all connected MIDI devices. You can select various All Note Off options with the MIDI Option dialog above. Duplicated in Panel Toolbar.

Set File Paths - Allows you to specify startup file paths for the patch, macro, function and other data folders. The default paths are usually in the Public Documents folder, but you may set them to any folder for which you have read/write permission. Use the NewRootPath button to change the root path of the folders, or the DefaultRootPath button to restore to the original default paths.

No actual changes are made by these buttons, they are only used to set up the names. Use the Change, Move, or Clone button to implement the change, or discarded if you click on Cancel.

Change button - Changes all paths but does not copy files from the current path. Creates directories if they do not exist.

Move button - Moves all paths and their files from the existing paths to the new paths. Moves complete path structure, including subdireories and files. Files already on the target path are overwritten.

Clone button - Copies all paths and included files from the existing paths to the new paths. Copies complete path structure, including subdireories and files. Files already on the target path are overwritten.

Cancel button - do nothing, just exit.

Bio Pitch Tables - Pops up a dialog box with 21 sliders for the pitch tables for bio sequence Amino Acid Notes.  This is the set of pitch translation tables for the 21 possible amino acid values produced by the Bio Sequencers and accessible with the AANote module.

Global Options - Customize some of the default MusicWonk global settings:

Play Button on Taskbar Tray - Duplicates the Play button on the Windows Taskbar tray, giving the ability to "remote control" MusicWonk while it is minimized or behind other program windows.

Only Show when Minimized - Only shows the Play button in the Windows Taskbar tray when MusicWonk is minimized.

Mouse Wheel Sensitivity - adjust mouse wheel response sensitivity. Set to 0 to disable mouse wheel.

Module Graphics Display Rate - sets the interval in milliseconds that the module readout values are updated. The default is 200 milliseconds, 5 times a second, which is about as fast as you can make sense of them, and has minimal impact on CPU usage. This does not affect readouts in the Panel, which always display instantly when changed.

Widget Fast Frame Move Threshold - When moving a group of widgets, if the number of widgets you are moving is greater than the threshold, only the frame will show as the widgets are being moved. This increases performance at the cost of not being able to see each widget as it is being moved. The default threshold is 8, so moving 8 or fewer widgets will show each widget during the move, moving more than 8 at a time will show only the frame. Faster computers can display larger numbers of widgets during a move without bogging down, so the default threshold of 8 can be changed to any number you like from 1 to 256.

Display Behavior on Minimize - 'Follow Art Wonk Window' connects the graphics screens (Canvas and Screens 1-4) to minimize with the main window. 'Remain Visible if ON' allows the graphics screens to remain visible when you minimize the main ArtWonk window.

Display Output Precision - sets the floating point precision module outputs display. Actual precision is unchanged.

Set Default Colors - check to return the Panel and Workspace to the default colors.

Panel Back Color - click on the button to change the Panel background color.

Workspace Back Color - click on the button to change the Workspace background color.

Reset Defaults - Removes custom settings by deleting the MusicWonk.ini file. Note that MusicWonk does not store its settings in the Registry; instead are stored in the MusicWonk.ini file in the .awi files in the Settings folder.

Clear Snapshots - Erases all Snapshot settings, leaving them all set to the current widget values as the default.

Save Window Size - Saves the current window size as the default.

Panel Grid & Workspace Grid -controls the screen area snap grid and the displayed grid which may be different from the snap grid. The default snap is 4x4, so as you move items in the Panel or Workspace, they will automatically adjust to the grid when you finish the move. To see the grid outline, select "Show Grid," and set the Width and Height values in of the grid size in pixels. Set the Min (minimum display grid size) to make the display different from the snap grid. For example if you set the snap grid size to 2x2 but the Min. to 8, the snap grid will be 2x2 as set, but the display grid will be 8x8, minimum allowed for display.

Use Fast Clocks - Determins whether MusicWonk uses fast response clock timers. Windows 2k, XP and later will get better performance with this option checked. Slower computers and Windows versions below 2K may have stability issues with it checked.

Run High Priority - Check to run MusicWonk at a higher priority than most (but not all) other tasks. Helps maintain smooth real time MIDI messaging at the expense of some stability. Usually OK on faster and/or multiprocessor computers. Not recommended for slower (< 1 GHz) processors).

Beep on Process Exit - Depending on the memory allocated, files opened, and Macro or Function additions or updates, MusicWonk can be quite slow to completely shut down. This is not normally noticable because when you exit it immediately shuts down its module processing and then does its clean up as a hidden background task. Select this option if you want to hear a beep when the cleanup process exits.

Vista Areo - Only available when running in Vista. Some Vista implementations are unacceptably slow displaying the standard drag and drop box when Areo is turned on. The solution to this can be either to set Vista to not use Areo when running MusicWonk (found in MusicWonk.exe properties), or to check this option which displays a simple arrow icon for drag and drop when making module connections. This option is on by default when running in Vista and later.

Update Mac/Func Doc (normally not visible) - Updates the user created help and label strings in Macro and Function Modules. Normally this is handled automatically, but USB key versions need to do this manually whenever the path changes, such as when the USB drive letter changes when changing computers. Only needed when button is visible. Update is processed in the background upon program exit.

Patch Options - Authoring options can be set here or with the System Modue property button, and are saved with the .awp patch file. Loading a patch file will update these parameters. All are off by default except the first.

Play Button Resets - Resets the Patch when the Play Button is clicked. On by default.

Hide Snapshots - Hides shapshots from the panel menu making snapshot access available only via the System Module

Set Workspace and Panel to Current Colors - Overrides the default colors to enable Save with custom Panel and Workspace color selections.

Maximize Panel Window on Load - Sets Program Start up with Panel maximized. (Workspace is not displayed in the window)

Random Numbers repeat after Reset - Check for repeating RNG sequence numbers starting at Reset. Uncheck for non-repeating numbers. Each check creates a different starting seed.

Password Protect Modules in Patch File - When checked, the Panel of the Patch file remains visible but the Workspace becomes hidden and Workspace modules are protected from unauthorized modification.

Use Names Subfolder - Check to select a sub folder of the Names folder for Program and Bank names, uncheck to return to using the bank and program name files in the main Names folder. See the readme.txt file in the Names folder for details on setting up custom names.

Install Packages - Opens the interface to Install, Update/Pack, or Uninstall ArtWonk/MusicWonk Packages.


MIDI Menu

Pops up the MIDI Options dialog, so you can set MIDI input and output devices and other MIDI related options.


BioEditor

The BioEditor converts data from DNA and protien sequence text files into a numerical table format (.bst). Although there are a number of controls in the BioEditor, most of them are for delimiting secondary structure features such as turns, alpha helixes, and beta sheets - which can be used to trigger musical changes or events. For a simple, direct translation of the protein or DNA data, you need only to read in the file and set markers for the beginning and end of the data. For more information on how to use the BioEditor to discover the sounds of DNA, see the BioEditor Help files and the BioEditor Tutorial.


DataBin

DataBin converts text data into binary number files. DataBin reads just about any text based data file with numbers in any range. Once the source data file is read into the text window, you can pick whether to convert all numbers, or select a field and convert just the numbers in that field. The values you select are charted in the graphical display window, to give you a quick idea of the data's shape. You can save it as a binary file with the data normalized to the 0-127 MIDI range, or as the original values in either floating point or ArtWonk sequencer/array format. See the DataBin Help files for complete information.


MicroTone

MicroTone creates microtonal tunings by automatically combining MIDI Note and MIDI Pitch Bend. The program does not generate music, rather it generates a set of tables that will translate MIDI notes of an arbitrary tuning table (such as Just Intonation) into MIDI Notes and Pitch Bend values that will give the correct pitch for each scale step. See the MicroTone Help files for complete information.


Help Menu

Online Manual - opens this help document.

Packages - Menu of help documents for any Packages that are installed. Not visible if no Packages have been installed. Package documentation is shown in the default browser rather than this compiled Help, so users can create and edit their own Package Help documents.

About - About this software info box that includes version and license information.

Visit Web Site - Opens your default browser to the Algorithmic Arts web site.

Register - Contains information and link button to purchase a license key, and the dialog to register your key when it is emailed to you.

MusicWonk is Copyright © 2003-2010 by John Dunn and Algorithmic Arts. All Rights Reserved.